61% des sites WordPress sont vulnérables en raison du PHP obsolète

61% des sites WordPress sont vulnérables en raison du PHP obsolète dimanche, août 4, 2019

Les bénévoles du développement WordPress ont publié une proposition pour inciter les utilisateurs de versions potentiellement vulnérables de PHP à les mettre à niveau.

Un nombre alarmant d'utilisateurs de WordPress utilisent toujours des versions PHP qui ne reçoivent plus de mises à jour de sécurité.

 

WordPress s'adresse à 61,6% des éditeurs vulnérables

PHP est le langage de script sous-jacent sur lequel WordPress s'exécute. La version la plus récente est “PHP 7.3.7”.

PHP est continuellement mis à jour pour le rendre plus efficace et pour corriger les problèmes de sécurité. Sauf les versions qui ont atteint le statut de « Fin de Vie » (EOL pour End Of Life).

Les versions PHP 5.6 et 7.0 ont atteint leur fin de vie en Décembre 2018.

La version PHP 7.1 atteindra sa fin de vie en Décembre 2019.

Selon les statistiques officielles de WordPress, 45,3% des éditeurs WordPress exécutent leurs sites sur les versions PHP 5.6 et 7.0.

De plus, 16,3% des sites wordPress utilisent des versions encore plus anciennes que 5.6.

C'est un total de 61,6% des éditeurs WordPress qui utilisent des versions de PHP qui ne reçoivent plus de mises à jour de sécurité.

Et ce, contre 57% au mois de Novembre 2018. Soit une augmentation de 4 points en 8 mois.

61,6 % des éditeurs WordPress sont vulnérables

Cela signifie que 61,6% des utilisateurs de WordPress peuvent être vulnérables aux événements de piratage.

La proposition de WordPress est de mettre tous les utilisateurs de PHP obsolètes à jour en utilisant un écran de “notification”.

Cela signifie atteindre (et forcer) tous les utilisateurs de WordPress 5.6 et en dessous, plus ceux qui utilisent encore la version 7.0.

La feuille de route suggérée pour augmenter la version PHP minimale est la suivante :

  1. Afficher le widget de mise à jour de PHP pour PHP 5.6. Cela déclenchera le widget pour toute personne utilisant PHP 5.6 ou au-dessous et WordPress 5.1 dans leurs tableaux de bord les avertissant du fait que WordPress recommande la mise à niveau de la version de PHP.

  2. Afficher le widget de mise à jour PHP pour les utilisateurs de PHP 7.0 et au-dessous.

  3. Basé sur le support et les statistiques des points 1 et 2, avoir une discussion sur la question de savoir si la prochaine étape devrait être l'affichage du widget de mise à jour PHP pour PHP 7.1 ou une augmentation directe de la version minimale requise à PHP 7.2.

Proposition WordPress pour les notifications

La proposition officielle de WordPress appelle à un écran de novice pour afficher. L'écran de “notification” exhorte les utilisateurs à mettre à niveau leur PHP.

Voici ce que l'annonce officielle indique: “Je voudrais proposer que nous déclenchions l'affichage du widget de mise à jour PHP pour les utilisateurs de PHP 5.6 dans WordPress.

Au moment d'écrire ces lignes, les statistiques de WordPress montrent que :

  • PHP 5.6 a une part d'utilisation de 29,1%
  • PHP 7.0 a une part d'utilisation de 16,2%
  • PHP 7.1 a une part d'utilisation de 13,2%

Le premier écran de notification peut commencer à être montré dès le 5 août 2019.

Les écrans de notification subséquents seront déterminés à une date ultérieure.

Voici le calendrier proposé :

Nous suggérons de commencer à afficher la recommandation de mise à jour pour les utilisateurs de PHP 5.6 ou moins à partir du 5 Août 2019.

Le calendrier pour montrer l'avertissement aux utilisateurs PHP 7.0 sera annoncé dans un post à suivre, et s'appuie sur des facteurs comme le support du téléchargement, et le taux d'adoption à partir de l’augmentation précédente.

Source : arobasenet.com





« Retour